Cannot connect

Jul 16, 2013 at 8:25 AM
I've installed ScrumFactory on a Windows 7 machine with IIS7. When I try to log-in it throws the following exception:
No se pudo resolver el ensamblado 'ScrumFactory.csdl'.
   en System.Data.Metadata.Edm.MetadataArtifactLoaderCompositeResource.LoadResources(String assemblyName, String resourceName, ICollection`1 uriRegistry, MetadataArtifactAssemblyResolver resolver)
   en System.Data.Metadata.Edm.MetadataArtifactLoaderCompositeResource..ctor(String originalPath, String assemblyName, String resourceName, ICollection`1 uriRegistry, MetadataArtifactAssemblyResolver resolver)
   en System.Data.Metadata.Edm.MetadataArtifactLoaderCompositeResource.CreateResourceLoader(String path, ExtensionCheck extensionCheck, String validExtension, ICollection`1 uriRegistry, MetadataArtifactAssemblyResolver resolver)
   en System.Data.Metadata.Edm.MetadataCache.SplitPaths(String paths)
   en System.Data.Common.Utils.Memoizer`2.Result.GetValue()
   en System.Data.Common.Utils.Memoizer`2.Evaluate(TArg arg)
   en System.Data.EntityClient.EntityConnection.GetMetadataWorkspace(Boolean initializeAllCollections)
   en System.Data.Objects.ObjectContext..ctor(EntityConnection connection, Boolean isConnectionConstructor)
   en System.Data.Objects.ObjectContext..ctor(String connectionString, String defaultContainerName)
   en ScrumFactory.Data.Sql.SqlTeamRepository.GetMember(String memberUId) en C:\Users\marcos.martins\Documents\Visual Studio 2010\Projects\thescrumfactory2012 - trunk\ScrumFactory.Data.Sql\SqlTeamRepository.cs:línea 64
   en ScrumFactory.Services.Logic.AuthorizationService.GetOrCreateMember(String memberUId, MemberProfile memberInfo) en C:\Users\marcos.martins\Documents\Visual Studio 2010\Projects\thescrumfactory2012 - trunk\ScrumFactory.Services.Logic\AuthorizationService.cs:línea 169
   en ScrumFactory.Services.Logic.AuthorizationService.SignInMember(String providerName, String token) en C:\Users\marcos.martins\Documents\Visual Studio 2010\Projects\thescrumfactory2012 - trunk\ScrumFactory.Services.Logic\AuthorizationService.cs:línea 82
   en SyncInvokeSignInMember(Object , Object[] , Object[] )
   en System.ServiceModel.Dispatcher.SyncMethodInvoker.Invoke(Object instance, Object[] inputs, Object[]& outputs)
   en System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeBegin(MessageRpc& rpc)
   en System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage5(MessageRpc& rpc)
   en System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage31(MessageRpc& rpc)
   en System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet)
Any help would be apreciated.
Thanks a lot
Coordinator
Jul 17, 2013 at 12:16 PM
Hi,
looks like a probleam at the connection string at the web.config file.

The following links may help you to solve the issue:

http://stackoverflow.com/questions/689355/metadataexception-unable-to-load-the-specified-metadata-resource
http://stackoverflow.com/questions/1074337/metadataexception-when-using-entity-framework-entity-connection

hope it helps

cheers
Jul 18, 2013 at 7:02 AM
Thanks!! It solved my problem!!
The problem was de connectionstring:
I had:
metadata=res:///ScrumFactory.csdl|res:///ScrumFactory.ssdl|res://*/ScrumFactory.msl;provider=System.Data.SqlClient;provider connection string="Data Source=192.168.1.112;Initial Catalog=ScrumFactory;User ID=sf_db_user;Password=sf;MultipleActiveResultSets=True"
Instead of the correct one:
metadata=res://*/ScrumFactory.csdl|res://*/ScrumFactory.ssdl|res://*/ScrumFactory.msl;provider=System.Data.SqlClient;provider connection string="Data Source=192.168.1.112;Initial Catalog=ScrumFactory;User ID=sf_db_user;Password=sf;MultipleActiveResultSets=True"