This project is read-only.

Problem to Connect

May 21, 2012 at 9:03 PM

Dear Sir,

I can not connect to the application or Google or Login Authentication.

know which can be

regards,

Marcelo Bilonia

Coordinator
May 24, 2012 at 12:17 AM

Hi,

I would sugget the following steps:


(1) Make sure you are connecting at the right server address.
At the right corner of the login screen, the server address should be: http://YOUR_SERVER/YOUR_APP_NAME

(2) Regarding the Google Authentication, if your network has a firewall/proxy, you may need to configure it at the server web.config, using the standards tags: <system.net><defaultProxy> …

(3) Regarding the Windows Authentication, the Server tries to detect and connect to your domain server. Sometimes you may need to specify your domain server name using the following tag at web.config appSettings:

<add key="WindowsAutheticationServer" value="YOUR DOMAIN NAME" />

hope it helps

Jul 24, 2012 at 2:28 PM
Edited Jul 24, 2012 at 2:30 PM

Hi,

 

Can't login  not with Google not with Windows too.

Each time the Authorization window back.

I have IIS 7.5 and SQL 2012 express.

Look's like the problem here:

 

HttpResponseMessage response = client.Post(Url("ValidTokens/" + providerName + "/"), 
new ObjectContent(token, JsonMediaTypeFormatter.DefaultMediaType));

Maybe need to create memberprofile before? Please advise. 10x

Coordinator
Jul 25, 2012 at 12:11 AM

Hello Olmer,

looks like the server is not able to validate the access token.
I would check those things:
1. Can you connect at the demo server (http://www.scrum-factory.com/demo) ?
2. Can you access the WCF authentication service http://<YOUR SERVER>/<APP NAME>/AuthorizationService/help ?
3. Is there anything at the App_Data/log.txt
There is no need to create a member profile.
It will be created at the server side the first time you login.
Please let me know if it helps you.
Cheers
Jul 25, 2012 at 6:56 AM

Hi, Thanks for quick response.

1. Yes. I can connect demo server

2. Yes. I can.

3. Nothing, file not exist.  Required permissions exists on the folder.

Still have same problem.

Please advise.

 

 

Coordinator
Jul 25, 2012 at 10:52 PM

Hi Olmer,

We still looking this issue, but I was able to simulate the same behaviour you have described when using a network that requires Proxy Authentication.


Is that your case, does your network use any proxy?

If so, you can try to use the <defaultProxy> tags at the server web.config.

 

 

Jul 26, 2012 at 6:34 AM

Hi,

I have corporate network, i don't know how we connected to internet provider. For sure we have several firewalls in the topology.

Maybe the company use it...but i don't have way to check it.

BUT Windows Authenication should be very simple and that what i'm looking for.

 

Coordinator
Jul 26, 2012 at 1:16 PM

Hi Olmer,

The Google Login Issue should be related with the proxy/firewall.

Regarding Windows Authentication, I would suggest two configurations:

  1. Add the following key at the web.config appSettings:

    <add key="WindowsAutheticationServer" value="<MY COMPANY DOMAIN NAME>"/>
  2. At the IIs admin, selects the WindowsAuth folder and enable Windows Authentication only at this folder.
    The anonymous authentication should be disabled at this folder also. 

Hope it helps.

 

Jul 26, 2012 at 3:13 PM
Edited Jul 26, 2012 at 3:14 PM

Thanks.

Done, without change. Still have the same problem.

Coordinator
Jul 27, 2012 at 12:07 AM

Sorry Olmer and thanks for your time and patience,

We still trying to reproduce the error behavior you described it.

We have just released a new server version (2.50 B) that provides more detailed error info at the login screen.

You can install it, and see if give us any clue of what is happing. 

Jul 29, 2012 at 7:57 AM
Edited Jul 29, 2012 at 10:46 AM

Hi,

Thank you!

Still have the same issue. No errors.

Maybe this info can help you:

Windows 7 64bit with IIS 7.5

Organizational AD

When i clicking on Windows Domain Account, i have new small window:


 Scrum Factory - Windows Authentication

domain.com

Sign in with username@domain.com

Sign in
Or click here to sign in with another user

 


 

domain.com - correct domain name

But e-mail wrong!!!! We are using in our company the strcuture below:

firstname.lastname@domain.com

 

 

 

Aug 16, 2012 at 11:33 AM

same issue, came out with this message:

"The Scrum Factory Server could not validate credentials against the authenticator provider"

Aug 22, 2012 at 3:55 AM

I solve the problem...

the issue (error) because in previous i user IIS 6 (windows 2003)

nom i'm using

IIS7 (windows 2008 R2) and it works flawlessly

Thankyou,

Nov 6, 2014 at 4:58 PM
Edited Nov 6, 2014 at 4:58 PM
I am getting following error in appdata/log.txt


03/09/2013 14:28:37
Unauthorized
em ScrumFactory.Services.Logic.AuthorizationService.CreateAuthorizationForToken(String providerName, String token) na C:\Users\marcos.martins\Documents\Visual Studio 2010\Projects\thescrumfactory2012 - trunk\ScrumFactory.Services.Logic\AuthorizationService.cs:linha 206
em ScrumFactory.Services.Logic.AuthorizationService.SignInMember(String providerName, String token) na C:\Users\marcos.martins\Documents\Visual Studio 2010\Projects\thescrumfactory2012 - trunk\ScrumFactory.Services.Logic\AuthorizationService.cs:linha 74
em SyncInvokeSignInMember(Object , Object[] , Object[] )
em System.ServiceModel.Dispatcher.SyncMethodInvoker.Invoke(Object instance, Object[] inputs, Object[]& outputs)
em System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeBegin(MessageRpc& rpc)
em System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage5(MessageRpc& rpc)
em System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage41(MessageRpc& rpc)
em System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage4(MessageRpc& rpc)
em System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage31(MessageRpc& rpc)
em System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage3(MessageRpc& rpc)
em System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage2(MessageRpc& rpc)
em System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage11(MessageRpc& rpc)
em System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage1(MessageRpc& rpc)

em System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet)